Refining Selections using Adobe Photoshop CC 2015.5 new Select and Mask workspace


Considerations when making a selection:
Backgrounds should be contrasty to get clean cutouts. For example, black hair should not be on a black
background when cutting out people. Therefore, when taking your photo, consider the background and make
sure there is sufficient contrast between the subject and background. If you are photographing people, place a
light gray background behind the subject or a white background if you move your subject away from the
background. Do not use a green or blue screen behind your subject since there will be color contamination.
Light your subject using a small Softbox (26"x26" positioned 45° from your subject) if you are not doing a full
body composite. Then place a Stripbank rim light (14"x35") 180° opposite the Softbox giving a harder side light
to your subject. When you place your subject between the two lights, it may be necessary to feather the Softbox
light by rotating the light towards the camera position so you get a softer light.
Before making a selection make sure you reduces noise to get a more precise selection. Also you should
duplicate the image so have a good reference below the selection image. When you make a selection don't
forget to use the Edit in Quick Mask Mode (Q) to refine your selection. Also consider using one of the RGB
Channels using the procedures described above. Select and Mask workspace can be used to correct hairy, furry,
fuzzy, and blurry areas of your selection.
If you make a selection first before opening Select and Mask workspace, do not make a selection over
transitional areas such a flyaway hair. It's important to stay away from the edges with your selection on tricky
areas when background show through items such as hair.
Technique tip to increase contrast when combining two different images (composition): Open the image into
Photoshop that you will be making a selection. The ACR dialog box should open and then increase the exposure
so that you have as much contrast between the selection area and the background as possible. Then depress the
Shift key and depress the Open Image button. This will load the image into Photoshop as a Smart Object
allowing you to return later and reduce the exposure and make other adjustments. Next make a selection of the
object and click on Select and Mask in the Options bar. Output your selection as a Layer Mask. You should have
one Layer containing a thumbnail of the original image and a Mask. Next drop this file into your background file.
Because the selection layer is a Smart Object, you can easily return to ACR and reduce the exposure and make
further adjustments to blend the selection with the background.
You need to accept that not every hair strand can be selected. However, you will get acceptable selection detail
when using the Select and Mask feature.



Select and Mask:
The Select and Mask workspace replaces the Refine Edge dialog in earlier versions of Photoshop, offering the
same functionality in a streamlined way.
Several bugs have been reported to Adobe. This new feature only works on a pixel layer (duplicate your
Background Layer to get a pixel layer). A workaround is available by double clicking a layer mask to enter the
Select and Mask space on a non-pixel layer. Adobe reports they are working on several fixes and request if you
have a problem to send them your file.
This workspace works best if you have a high resolution photo.


To invoke the workspace, click Select and Mask in the Options bar when a selection tool is enabled.
Alternatively, you can press Ctrl+Alt+R or choose Select>Select and Mask. You can also click on Select and
Mask in the Properties panel for a Layer Mask.



You can set the default tool behavior, such that double-clicking a layer mask opens the Select and Mask
workspace. Simply double-click a layer mask for the first time and set the behavior. Alternatively, select
Preferences>Tools>Double Click Layer Mask Launches Select and Mask Workspace.



Tools (left panel):

o

Quick Selection Tool: Make quick selections based on color and
texture similarity when you click or click-drag the area you want to
select. The mark you make doesn’t need to be precise, because the
Quick Selection tool automatically and intuitively creates a border.

o

Refine Edge Brush Tool: Precisely adjust the border area in which
edge refinement occurs. For example, brush over soft areas such as
hair or fur to add fine details to the selection. To change the brush
size, press the bracket keys. Generally you only need to click on the
Refine Edge Brush Tool to paint over edges of your selection in order
to fine-tune your selection. Magnify closer to the selection and paint
over the areas that needs to be better defined. If you depress the Alt key and click over an area, it will
sample the color under the cursor and remove that color from the selection.

o

Brush Tool: Begin with making a rough selection using the Quick Selection tool (or another selection
tool) and then refine it using the Refine Edge Brush tool. Now, use
the Brush tool to finalize or clean up details.
Use the Brush tool to fine-tune selections in two simple ways: paint
over the area you want to select in the Add mode (brush default), or
paint over areas you don’t want to select in the Subtract mode (hold
down the Alt key). If you click on the minus icon on the options bar,
you must depress and hold down the Shift key to return to the plus
or add mode.
With the Brush tool selected and over the on-screen preview, you
can right-click and the popup dialog will allow you to change the
Brush size, hardness, and spacing.





o

Lasso Tool: Draw freehand selection borders. Using this tool, you
can make precise selections.

o

Hand Tool: Navigate around the photo. This photo works just like
the Hand tool in classic Photoshop

o

Zoom Tool: Magnify and navigate around the photo; works just like the Zoom tool in classic Photoshop.
You can also hold down the Z key to bring up the Zoom Tool and continue to click to zoom in. To zoom
out hold down the Z+Alt keys. To return to full screen, depress the Ctrl+0 keys.

Options bar:
o

Add or Subtract: Add or subtract from the refinement
area. Adjust the brush size if necessary.

o

Sample All Layers: Creates a selection based on all layers instead of just the currently selected layer

Refine the selection: You can refine your selection in the Properties panel of the Select and Mask
workspace. Adjust the following settings:
o

View Mode settings: From the View pop-up menu, choose one of the following view modes for your
selection:


Onion Skin (O): Visualizes the selection as an animation-style onion skin scheme. This view is
generally the best of all the views but it is important to lower the Transparency to 20-30%. If the
transparency is 100%, the background will be pure white; however, lowering the transparency shows
you where to paint over along the edges.



Marching Ants (M): Visualizes the selection borders as marching ants. Marching Ants view mode is
not generally useful in seeing your selection.



Overlay (V): Visualizes the selection as a transparent color overlay. Unselected areas are displayed
in that color. The default color is red.



On Black (A): Places the selection over a black background



On White (T): Places the selection over a white background



Black & White (K): Visualizes the selection as a black and white
mask. To see any detail that might have been missed, switch
the View to Black and White. The selected areas will be white
and if you see some gray areas that you don't want selected
then paint them out or raise the Contrast to clean up the edges.



On Layers (Y): Surrounds the selection with areas of
transparency
Note: Press F key to cycle through the modes and X key to
temporarily disable all modes.

o

Show Edge: Shows the area of refinement.

o

Show Original: Shows the original selection.

o

Transparency/Opacity: Sets transparency/opacity for the View
Mode. This setting applies beyond the Select and Mask workspace to
the Overlay view mode in classic Photoshop.

o

Edge Detection settings: You can see the radius in the document
window by checking Show Radius box and then increasing the
Radius slider. However, if some areas are outside the Smart Radius
area, increase the Radius and then paint over the selection area.
Usually a value of 5 to 15 pixels works well; however, each photo is
different and you will need to experiment with the Radius pixel
amount. This allows you to selectively expand your edge detection
area, bringing in more details from the subject as Photoshop learns
what is and isn't background. Think of the Radius slider as paining
around the entire selection at once. If you increase the size of the
Radius too much, unwanted background areas may start blending
into the selection, and you can even lose areas that you initially
selected and wanted to keep.
 Radius. Determines the size of the selection border in which
edge refinement occurs. Use a small radius for sharp edges, and a large one for softer edges.
 Smart Radius. Allows for a variable width refinement area around the edge of your selection. Among
other use cases, this option is helpful if your selection is a portrait that includes both hair and
shoulders. In such portraits, the hair might require a larger refinement area than the shoulders,
where the edge is more consistent. Once you've enabled Smart Radius, you'll usually want to readjust the Radius size with the main slider to see if you can get even better results. Normally do not
exceed a radius of 20-pixels, otherwise you will get undesirable results.
Important: Try turning Smart Radius on and off to see if this option helps.

o

Global Refinement settings: Generally you will not need to use these adjustments sliders with the
exception of Shift Edge.
 Smooth: Reduces irregular areas (“hills and valleys”) in the selection border to create a smoother
outline. Normally Smooth Edge doesn't do much. Be aware that using too high a Smooth value can
“clip” small details along the edge of the selection.
 Feather: Blurs the transition between the selection and the surrounding pixels.
 Contrast: When increased, soft-edged transitions along the selection border become more abrupt.
Typically, the Smart Radius option and refinement tools are more effective. Usually you will not use
any contrast adjustment. It generally ruins the edge when overdone, so keep it below 10%.

However, if you want a sharp defined edge then increase the Contrast slider about half way and see
what happens.

o

Shift Edge: Moves soft-edged borders inward with negative values or outward with positive ones.
Shifting these borders inward can help remove unwanted background colors from selection edges.

Output Settings
 Decontaminate Colors: Replaces color fringes with the color of fully selected pixels nearby. The
strength of color replacement is proportionate to the softness of selection edges. If you see a lot of
fringing around hair, which is caused by remaining color from the original background, then use
Decontaminate Colors option.
Important: Because this option changes pixel color, it requires output to a New Layer or document.
Retain the original layer so you can revert to it if needed.
 Output To: Determines whether the refined selection becomes a selection or mask on the current
layer, or produces a new layer or document. Normally will want to output your cutout to a New
Layer or New Layer with Mask.

Reset: Click
to reset the Workspace and revert the settings to the original state in which you entered the
Select and Mask workspace. This option also reverts to the original selections/masks applied to the image
when you entered the Select and Mask workspace.
Remember Settings: Select Remember Settings to save the settings for use with future images. The settings
are applied afresh to all future images, including the current image if it is reopened in the Select and Mask
workspace.




Shortcut keys:
o

Depress the 'P' key to see a before & after preview.

o

Depress the 'F' key to cycle through the view modes.

Recommended steps to refine your selection using Select and Mask workspace.
1. Either start with a selection, or open the Select and Mask workspace. Choose the Onionskin View mode
and choose a selection tool from the Tool bar.
2. If there are any areas of your image not selected that should be, use the Quick Selection tool to paint
them in quickly.
3. Select the Refine Edge Brush and start by clicking on the background area outside your selection to
define the hue you want to mask out, then drag the brush into your edges/hair. The more you refine the
selection, the smarter it gets and the whole edge begins to look better.
4. Slide your Transparency slider up to 100% so you can view the cut out on its own and view any
additional areas that need fixing.
5. Turn on Smart Radius in Edge Detection section. Select a radius of 5-px since this will help bring in some
of the finer details.
6. In the Output Settings, check the Decontaminate Colors box to remove any remaining hue around the
edges of your selection.
7. Use the Global Refinements sliders to fine tune your selection. The one most likely slider to use is the
Shift Edge to reduce the selection which will remove unwanted areas around the edges.
8. Select the Black & White view and use the Brush tool to mask in or out (depress Alt key) any remaining
sections especially near the edges of the cutout.
9. When you’re happy with your selection, click on the Output dropdown menu and choose your output
method. In most cases for a non-destructive workflow, choose New Layer with Layer Mask.

10. Check the Remember Settings box if you plan on doing multiple cutouts of the same type of image and
press OK to confirm you are finished.


Recommended steps after you output your selection to a new Layer:




Before refining your mask, make a copy of your selection in order to revert to the original selection:
o

Ctrl-click on the mask to bring up the marching ants.

o

Select Channels and make a copy of your mask (click on 'Save selection as channel' icon at bottom of
panel).

Defringe halo/white around edges:
o

First method:
 If there are extra pixels around a selection, creating a halo effect, defringe the selection.
 Copy the selection onto a new layer. If you already made a Mask, the Ctrl-click on the mask to bring
up the selection on the image (marching ants) and then depress Ctrl+J. This will place the selection
onto a new layer with transparent areas around the selection.
You can also right-click the mask and select 'Apply Layer Mask' which will apply the selection on a
new layer with a transparent background.
 Before attempting any fix, zoom in on the fringed edge to readily see the problem and how the
solution is working. Determine the width of the fringe in pixels.
 Choose Layer>Matting>Defringe. Then select 1 pixel for the
width or the number of pixels you determined by zooming in
close to the edge. If that doesn't work, then undo (Ctrl+Z) and
try 2 or 3 pixel Defringe.
 To see a before/after view, choose undo (Edit>Undo or Ctrl+Z)
and then an redo the Defringe adjustment (Edit>Redo; or Ctrl+Z).
 If the Defringe tool does not remove the pixels then choose Layer>Matting/Color Decontaminate.
This option changes the color of the stray pixels to match the color of a surrounding object.

o

Second method: If your cutout has a primarily white of black background, try going to
Layer>Matting>Remove White/Black Matte. If the background was primarily white this will remove the
white fringe around the cutout. Sometimes you may see some faint black smudges around the cutout
which can be removed by using the Eraser tool (background around cutout is transparent).

o

Third method:
 Duplicate the Layer and Zoom Into the fringe area.
 Apply a Gaussian Blur and increase the radius until the fringing color is gone. Use the minimum
amount of blur to remove the fringe color.
 Set the Blending Mode of the Blurred Layer to Color.


Add a Black Mask and paint with white over the fringe areas.

o

Fourth method:
 Click the fx button at the bottom
of the Layers panel and in the
popup select Inner Shadow.
 Click on the Set color of the
shadow swath box (same line a
Blend Mode indicated by red
arrow) and with the Color Picker
eyedropper select the dark hair
color of the cutout.
 Then move the Size slider to
remove the white fringe.



Try duplicating (Ctrl+J)the cutout layer.
For hair it may build up and enhance
some hair areas. However, you may not
get satisfactory results in other areas
when duplicating. Add a Layer Mask and paint out those areas.



Add a solid color layer: It is best to see your work against a solid background color (teal/green/magenta
color). Click on Create New Fill or Adjustment Layer icon (half circle) and select Solid Color. The Color
Picker will pop up and select a background color. Click on the new Color Fill layer and drag it below the Mask
Layer.

